• Firefox 3.5 and above
  • Microsoft Internet Explorer 7 and 8
  • Safari 4.0 and above
  • Google Chrome 6.x

NOTE: Pop-up blocking in your browser should be disabled when using Parallels Plesk Panel.
Microsoft IE 6 will work with Plesk 10 in most cases, but it is not recommended.  Microsoft IE 6 and below is not supported by SiteBuilder. 

  • 0 Users Found This Useful

Was this answer helpful?

Related Articles

Passwords must meet complexity requirements

This security setting determines whether passwords must meet complexity requirements. Passwords...

ASP.NET Permissions

In order to set ASP.NET permissions you will need to use the Plesk IIS WP User.  Login to your...

Can not display previous months / years in Awstats

This article applies to customers using the Plesk control panel. In order to view previous...

Control Panel Login

If you are a Plesk control panel customer you will want to refer to your confirmation e-mail that...

Create IIS application in Plesk control panel interface

- Login to your control panel interface, go to Websites & Domains -> (Show Advanced...